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PPrreeffaaccee                                                                      
  
  
Overview of SW_ROAD 
 
 
 
SW_ROAD is a road designing software package that is efficient, powerful, accurate and easy 
to learn. It generates precise road design outputs considering all the parameters of road 
design. It provides all the cross-sections, profile and final alignment design with the facility to 
design in a single screen at same time. The quantity calculation is done by the software and 
the data output is obtained in Excel, ready to print format, while the drawings of Cross 
Sections, Profile and Plan are obtained in AutoCAD file format. 
 
The software has been successfully implemented in number of roads project. During the year 
1995 – 1999 alone, WELINK Consultants (P) Ltd. has used the software for designing over 250 
Km / year for Computer Aided Design of Road for the Third road Project. Arniko Highway 
Maintenance Project (Barhabise – Kodari Sector) used SW_ROAD. WSP, one of the foreign 
Consultants worked in Road Sector, designed the road using SW_Road for their road project 
Harthok – Tamghas Road. Besides WSP, a large number of domestic consultants including 
GEOCE Consultant (P) Ltd. and SOIL Test (P) Ltd are also utilizing software SW_ROADS for 
the design and drawing of Roads. SIDEF and Royal Nepal Army has used this software. 
Recently, Roughton consultancy, Iteco consultancy and Fulbright consultancy is running 
RNDP (Road Network Development Project) by utilizing this software for designing and 
drawing. Several contractors have been using this software for effective and efficient work 
execution in the road construction too. 
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About this Manual 
 
The user manual contains the following chapters to guide through SW_ROAD software: 
 
Chapter 1- Introduction 
 
• Assistance for the installation of software. 
• History of the establishment of the SW_ROADS. 
• Brief description of the different projects that utilized this software.   
• Highlights on the contents of SW_ROADS. 
• Analysis the Data Files.  
• Demonstration about the format of the SW_ROADS. 
• Summary of input and output.  
• Instruction for running the SW_ROADS program. 

 
Chapter 2 – Commands 
 
• Description about all the commands in form of Menus in the software. 

 
Chapter 3 - Procedure 
 
• Description of step by step method for working with SW_ROADS. 
• To generate the alignment design along with profile and cross-sections with the extraction of the 

quantities. 
             
Chapter 4 – SW_ROAD Outputs 
 
• Description about the outputs that SW_ROAD can produce. 
• Explanation about the steps of getting outputs provided by the software. 

  
Chapter 5 - Sample Outputs 
 
• Captured pictures for the outputs given by the software. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

  
 

ix 

Convections used in this Guide 
 
 
The following convections are commonly used throughout the manual. Occasionally, when a menu 
item is referenced, its path will be written as:  
 

Menu Name > Sub- menu > Sub-Submenu, which follows the order of selection that the 
user must take.  
 

 Menu Name refers to the parent name for a pull-down menu. 
 

 Submenu refers to an item in the contents of the pull-down menu. 
 

 Sub-Submenu refers to an item in the contents of a menu, stemming from a Submenu  
 
 
For example: Data > Design Tables > Super elevation, refers to the Design Tables > Super 
elevation, option located in the Data pull-down menu.  
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INTRODUCTION 
                                          
                                                                                     
SW_ROADS: Road Design and Drawing Package 
                                                                                                                                                                                                                                                      
                                                                                             
This software is designed for the design and drawing of Road with quantity extraction. WELINK 
Consultants (P) Ltd, the parent organization of Softwel (P) Ltd., developed it earlier in 1993. The 
software was in Quick Basic language at the beginning.  
 
SW_ROADS has been improvised by SOFTWEL and it is now in windows version. The main 
executive module is written in Visual Basic. The software is able to design, produce all the required 
drawings (Plan, Profile and Cross Sections) in AutoCAD and extract the quantities of Earth works and 
Retaining Structures in Excel. The program has the provision for Super Elevation and Extra Widening 
too. Super Elevation can be shown in Profile as well as in Cross-Section, while the Extra Widening 
can be shown in Plan and Cross-Section. The program has the unique capability to extract the data 
for layout (Co-ordinates of the Centerline of Alignment or the Design Level, Super Elevation and Extra 
Widening Data) for any interval according to the requirement of the designer and construction 
engineer. 
 
SW_ROADS has been designed for design and drawing of all types of Roads in NEPAL in 
accordance with the Nepal Road Standards. All the Design Parameters can be given by the designer 
according to the requirement for the individual project. The main function of SW_ROADS allows the 
designer to choose the best alternative among many. It generates all the required drawings (Plan, 
Profile and Cross-Sections) with proper Sheet Planning. The drawing output from SW_ROADS is just 
about ready to print. 
 
The new version of SW_ROADS has its own independent window as working space. All the design 
work can be carried into a single window and final drawing is obtained in AutoCAD. The major benefit 
of the new version lies on the capability of working with Plan, Profile & Cross-section simultaneously 
in a single window. The change in any parameter, either in Plan, Profile or Cross-section is readily 
updated by just a single click in all the parameters and the visual effect can be seen. This provides the 
opportunity to the designers to visualize the effect of change in parameter of one component to 
others, which result into less time consuming design process. 
 
Furthermore, the new version of SW_ROADS has flexibility to work with AutoCAD too. Though one 
can choose to work with either CAD or program’s own window in the very beginning of project creation 
or opening, the mode can be switched while working whenever desired. 
 
 
Specifications 
 
• Built-in data sheets for Data entry for alignment, existing profile and design parameters. 
• Provisions for importing data from excel sheet as well as exporting it. 
• Switching of mode from program window to CAD window or vice versa. 
• Plan/Profile/Cross-Section can be viewed in same window. 
• Design, Drawing (Plan/Profile/Cross-Section) and Quantity off take all in one step 
• Features like proper sheet planning in AutoCAD which are ready to print. 
• Feature like plotting of existing Profile/Cross-Section. 
• It allows the user to design the alignment and profile with great simplicity. 
• Various structures can be applied in the cross-sections as per the requirement as well as 

removed. 
• Quantities of road parameters of all the structures including Pavement, Retaining walls, Drains in 

separate sheets. 
• It facilitates interactive design with high accuracy. 
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Minimum System Requirements 
 
• Computer with Pentium III processor or higher and at least 128 MB RAM (512 MB 

Recommended) 
• Excel 7.0 or advance 
• AutoCAD 2000 or higher versions 
• Windows XP 
 
 
 
 

Installation Notes and Software Initialization    
                                                                                                                                                                                       
 
INSTALLATION: 
 
SOFTWEL: SW_ROADS is provided in a CD and the program has to be installed from the CD. Follow 
the simple instructions to install the program. 
 
 
♦ The CD-ROM contains the Directory SW_ROADS_2005. 
♦ Open this directory and run the Setup icon (by double clicking). 
♦ Install key driver. 
♦ Install SW_Roads program. 
♦ Select directory of installation as “C:\Program Files\SW_ROADS_2005” and follow the screen 

instruction for proper installation. 
♦ The program will automatically generate a shortcut in “Program” menu as SOFTWEL> 

SW_ROADS_2005, with shortcuts on the desktop.  
 
 
Upon installation, the program makes following files to its default directory C:\Program Files 
\SW_ROADS_2005. 
 
 
Sw_Roads_2005.exe: Main executive module for design and generation of drawings 
SW_DTM_2005.exe: Program for Digital Terrain Modeling 
uCross_Editor:  Application file for cross-section design. 
Template: Folder containing Excel and AutoCAD template files for DTM, SW_ROADS and Cross-
editor. 
Structures: Folder containing structure’s (e.g. Drain, Retaining, Breast Walls etc) text file required for 
Cross- section. 
 
 
Notes: 
 
The Sw_Roads_2005 program is protected through hardware key lock. The hardware key is provided 
with the program CD which is needed for both the installation and operation processes. The serial 
number provided with the software CD is required to continue with the installation.  
 
By double clicking the setup icon, the program will launch the setup process. Follow the simple steps 
of general software setup. Provide the Serial Number provided with the CD and click Install. Note that 
the hardware key must be connected throughout.  
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Commands of Sw_Roads_2005  
 

 File: 
 
Before working with any project, File is the menu to be accessed either to create new projects or open 
the previously saved project. The various sub menus under the File menu are enumerated below: 
 

 
 

Fig: 2.1 
 
1. New Project: 
 
This command allows the user to create new project file. 
 
2. Open Project: 
 
When the previously created project has to be opened, this command is used.  
 
3. Save Project: 
 
The command allows saving the project. 
 
4. Design Mode: 
 
This allows users to switch between the Sw_Road based window to AutoCAD based window or vice-
versa.                     
 
5. Exit: 
    
This is the command to exit the program. 
 
 

 Data:   
 
The Data menu provides access to the data for design or existing data imported or manually entered. 
   

 
 

Fig: 2.2 
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1. Design Tables 
 
The design tables are the tables from which the program gets the value for the design. Two design 
tables can be found in this sub-menu. 

   
I. Super elevation 

   
This is the table in which the design data for super elevation is specified. The data can be imported 
from the Excel file as well as can be exported. 
 

 
 

Table no: 2.1 
 

II. Extra Widening 
    
This is the table in which the design data for extra widening is specified. The data can be imported 
from the Excel file as well as can be exported. 

     

 
 

Table no: 2.2 
 
2. Design Data 
     
The design data are provided under this sub menu. The different design data provided are as follows: 

 
1.  Parameters 
 
This sheet is to input the design data for the project. By default, the data in the sheet are for the 
Feeder Road design, but it can be modified as per the requirement of the Designer. When this sub 
menu is clicked, a sheet named “Design Data” is opened. 
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Table no: 2.3 
 

The different elements included in the parameter sheet are:  
 
A) Carriageway: 
      
Carriageway is defined as the road width where movement of the vehicles takes place. The designer 
gives Road width according to the design criteria and the standards for the road project. Camber is 
the slope provided to the road surface in the transverse direction of road to drain off the rainwater 
from the road surface. The required camber of a pavement depends on the type of pavement surface 
and amount of rainfall.   
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B) Vertical Alignment Design: 
 
The vertical alignment is the elevation or profile of the centre line of the road. It consists of grades and 
vertical curves, and is governed by the design speed, acceleration, deceleration, stopping sight 
distance and comfort associated with the vehicle movement. The design speed of roads depends 
upon the class of the road and terrain. 
 

 
 
C) Super Elevation Design:                
 
Super elevation is the transverse inclination to the pavement surface to counteract the effect of 
centrifugal force and to reduce the tendency of the vehicle to overturn. Super elevation is provided to 
the road by rotating the cross-section line about the center of the road.  
 

 
 
D) Extra Widening Design: 
     
Extra widening is simply the widening of road at horizontal curves. As the rear wheels of vehicle 
doesn’t follow the same path as front wheel at bends, the necessity of extra widening arises. It 
provides the easiness to the vehicle for the movement when the radius of horizontal curve is less.     
                   

 
 
E) Design Overrides for Hill Roads: 
     
It allows the user to specify the minimum curve length of the horizontal curves for which geometric 
design is to be carried out at super elevation and extra widening.    

 

 
 
F) Right of Way: 
 
Right of way is the area of land acquired for the road, along its alignment taken from center line of the 
road on either direction of the center line. 
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G) Starting Chainage: 
  
This table provides with the flexibility to assign the starting chainage as per the requirement of the 
user for the alignment. 
 

 
 
After entering all the design data, the data in the sheet are saved by clicking the “Save” button. 
 
2.  Hill Side Data 
 
Hillside data provides the program with the information in which side of the road does the hill lies. The 
code represents the side (1 for Right side hill and 2 for Left side hill). This data is required only in case 
of the camber side considering as hill side and not in two way camber. 
 

 
 

Table no: 2.4 
 
3.  Side of Extra Widening 
 
Side of extra widening is the provision of mode of placement of extra widening to the horizontal curves 
according to the radius of curve. The percentage value is assigned to the value of extra widening to 
place on either inner side of the horizontal curve or the outer. 
 

 
 

Table no: 2.5 
 
4.  Soil Type 
 
Soil type according to the chainage is defined in this field. Prior to defining the chainage, soil code has 

to be generated. This can be done by clicking   on the right corner as seen in the table below. Soil 
codes are the abbreviated form of the soil types defined in a manner that, when needed, they can be 
called by their abbreviated form. Similarly, cut, fill and foundation cut slopes are also defined in the 
code segment. Provision for importing the soil code is also available from the previously defined 
project from the excel file. 
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Table no: 2.6 
 

 

 
 

 
Table no: 2.7 

5)  User Chainage 
 
When remarks for the user-defined chainages have to be considered, this table is used. The users 
chainages can be imported from excel as well as can be exported. 

 

 
 

Table no: 2.8 
6)  Shoulder Data 
 
This table is used for providing the shoulder data for the road. The shoulder data include width and 
thickness for the desired chainage interval. The shoulder data can be imported from excel as well as 
can be exported. 
 

 
 

Table no: 2.9 
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7)  Pavement Data 
 
The thickness of the pavement is given in this table in terms of chainage range. 
 

 
 

Table no: 2.10 
 
8)  Variable Road Width 
 
For certain reach of road segments, sometimes-variable road width concept has to be adopted. 
Variable road width is entered in this table. 
 

 
 

Table no: 2.11 
9)  Pass-By 
 
For providing the pass-by at different chainages for smooth vehicle movement, data is entered in this 
table. 
 

 
 

Table no: 2.12 
 
 

3. Alignment 
 
Alignment data is obtained from the field as well as from the calculations. The alignment data is either 
entered manually for each Ip’s as calculated from the calculation or simply importing form the Excel 
sheet. The data to be entered are the IP no., Coordinates of IP (Easting and Northing) and the radius 
of the horizontal curve placed in between the line joining IP’s. 
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Table no: 2.13 
 

Upon clicking the “Save” button; the alignment is drawn in the program window, which is the required 
alignment as of data entry. 
 
4. Existing Profile 
 
The data for the existing profile is entered in this table either by entering the data manually or by 
importing the data from Excel file. The data to be entered are chainage, existing ground level (profile) 
and remarks, if any. 
 

 
 

Table no: 2.14 
 

By clicking the “Save” button of the existing profile table, existing profile is generated in the profile tab. 
 
5. Design Profile 
 
When the design ground level is drawn in the Profile tab of the program, the data is generated in this 
table. Alternatively, if the design data is in the Excel file, it can be imported.  
 

 
 

Table no: 2.15 
By saving the design data of the table, design line will be drawn. 
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6. Cross - Sections 
 
The data for the cross sections are entered in this table. It is measured on the different intervals of the 
chainage. The required data for the cross section are Chainage, Partial Distance (left to right with –ve 
for left side and +ve for right side), respective Reduced level and Remarks These data will have to be 
entered as in the sample sheet below. It is very important that there must be at least one point on 
each side, data for the center with PD is 0.00, and RL of center matches with the Existing RL entered 
in the Profile data. The data with partial distance 0.00 should not be repeated. 
 
The table has provision for inserting cross-section, deleting cross-section and also for interpolating the 
cross-section between two cross-sections, if required. The preview for each cross-section can also be 
seen by clicking preview button.  
 

 
 

Table no: 2.16 
 
Options 
 
This provides with the general options like changing the color of background, entering the interval of 
chainage to be marked on alignment. 

 

 
 

Fig: 2.3 
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 View:   
 

This menu provides the user to work with the drawing in regard to enlarging/reducing or panning.  
 

 
 

Fig: 2.4 
 
The different sub-menus under this menu are: 

 
1. Zoom In: 
 
This command allows the user to magnify the drawing. This function is also facilitated by keyboard                     
shortcut Ctrl + Ins. 
     
2. Zoom Out: 
 
This command allows the user to reduce the magnification of the drawing. This function is also 
facilitated by keyboard shortcut Shift + Ins. 
 
3. Pan: 
 
The command allows panning the drawing. This function is also facilitated by keyboard shortcut P. 
 
4. Zoom Window: 
 
This command allows user to magnify the portion of the drawing. This function is also facilitated by 
keyboard shortcut Ctrl + W. 

 
 
 Edit:   

 
The edit menu allows the user to change the parameters like super elevation and extra widening                     
along with adding/moving/inserting the nodes required for design.  
 

 
 

Fig: 2.5 
 
The sub-menus under this menu are:  

 
1. Super Elevation: 
 
This command allows the user to change the values of super elevation either for particular Ip or for a 
group of Ip’s. 
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Table no: 2.17 
 
2. Extra Widening: 
 
This command allows the user to change the value of extra widening for particular Ip or for a group of 
Ip’s. 
 

 
 

Table no: 2.18 
 
3. Erase Ip: 
 
This command allows erasing an Ip. This function is also facilitated by keyboard shortcut E. 
 
4. Select Ip: 
 
This command allows user to select an Ip. This function is also facilitated by keyboard shortcut S. 

 
3. Insert Ip: 
 
This command allows the user to insert an Ip in between two Ip’s. This function is also facilitated by 
keyboard shortcut I. 
 
4. Move Ip: 
 
This command allows user to move an Ip. This function is also facilitated by keyboard shortcut M. 
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 Utility:   
 

 
 

Fig: 2.6 
 

The sub-menus under this menu are: 
 

1. Update Terrain: 
 
When data of the terrain is changed during the design process, to mark the change, use this sub 
menu. This can be alternatively be done by clicking          button.  
 
2. Reset Dtm File Path: 
 
Generally, the design is commenced when the Digital Terrain Model is finalized through SW_DTM. 
But, sometimes it becomes necessary to make a new DTM file and to import in the SW_Roads. In this 
case by clicking “Update Terrain” would not provide the user with selection of the new DTM file. To 
mark the change in the DTM file, this sub menu should be clicked first before clicking on “Update 
Terrain”. 
 
3. Write Chainage: 
 
When it is desired to write chainage in the AutoCAD for an alignment, use this sub menu. 
 
4. ReCalculate SuperElevation: 
 
When the super elevation values for the Ip’s are altered afterwards than the initial design values, the 
recalculation of the super elevation has to be done. The recalculation of such value is done by this 
sub-menu.  
 
 
5. ReCalculate ExtraWidening: 
 
When the extra widening values for the Ip’s are altered afterwards than the initial design values, the 
recalculation of the extra widening has to be done. The recalculation of such value is done by this 
sub-menu.  

 
 
 Outputs:   

 
The outputs of the program in the form of data are obtained from this menu. All the data are produced 
in the Excel file format (*.xls) in the ready to print format. 



 

  
 

15 

 
 

Fig: 2.7 
 
The different data that are produced by the software are as follows: 
 
1. Horizontal Curve Data: 
 
All the details of the Horizontal Curve are obtained from this sub-menu. 
 
2. Vertical Curve Data: 
 
All the details of the Vertical Curve are obtained from this sub-menu. 
  
3. Property Line Co-ordinates: 
 
This command list layout co-ordinate for the property line along with the centerline co-ordinates and 
left to right cross bearing for each chainage listed. 
 
4. Generate Layout: 
 
This command allows the user to get centerline layout data along with left to right cross-bearing, road 
width, extra widening and pass by for desired interval of chainage. 
 
5. Quantity: 
 
The quantity of earthworks, structures, drains, pavement, and shoulder are obtained from this sub-
menu. 
 
 

 Drawing:   
 
The outputs of the program in the form of drawings are obtained from this menu. All the drawings are 
produced in the AutoCAD format (*.dwg) in the ready to print format. The different drawings that are 
produced by the software are as follows: 
  
1. Alignment: 
 
The designed alignment is drawn into AutoCAD through this sub-menu. 
 
2. Profile: 
 
The designed Profile is drawn into AutoCAD through this sub-menu.  

 
3. Cross-Sections: 
 
The designed Cross-Sections are drawn into AutoCAD through this sub-menu. Upon clicking this sub-
menu, a window named “Cross Editor” appears, through which the drawing of cross-sections is done. 
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Fig: 2.8 
 
 
 Tools:   
 

The tools menu is active only when the program is chosen to run in AutoCAD mode. Within the Tools 
menu, the different sub-menus are: 

  
1. Alignment Optimizer: 
 
The Alignment Optimizer is the window to help in designing the Alignment in the AutoCAD. 
 
2. Profile Optimizer: 
 
The Profile Optimizer is the window to help in designing the Profile in the AutoCAD. 
    
  

 Help:   
 

This menu provides the user to access the help file of the program. 
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Tabs/Working Windows 
 
 
On the bottom left of the main window there are different tabs displayed. The tabs offered are the 
different windows as the name of the tabs. Altogether there are five tabs as Plan, Profile, Cross-
Sections, Plan-Profile and Plan-Profile-Cross Sections which will open the respective window in the 
main program. 
 
1. Plan 
 
The plan window displays the plan of the drawing comprising all the elements of plan. A view of Plan 
window is shown below. 
 

 
 

Fig: 2.9 
 
 The different elements provided in the Plan window are as follows: 

 
 Ip Properties: 

  
The Ip Properties window displays all the elements associated with an Ip. All the elements like Extra 
Widening and Radius can be changed manually from this window. For magnifying the location of 
required Ip in the drawing, there is a provision of zoom icon at the top right side of this Ip property 
window. Clicking this will magnify the current Ip no. displayed in the Ip no. field placing at the center of 
the Plan window. 
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Fig: 2.10 
 

 Terrain Layers:   
 

The button at the bottom of this property window “Detail from Dwg File”, allows importing the 
different layers from the AutoCAD to the program. The layers selected from AutoCAD to import in the 
program are displayed under Terrain Layers. 

 

 
 

Fig: 2.11 
 
 
 Road Elements: 

 
The road elements property window is for placing the road elements like Chainage, Road Width,  
Staking etc. on the drawing displayed in main window. 
 

 
 

Fig: 2.12 
 
 

 
 
 
 
 
 

Zoom Button
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2. Profile 
 
The profile tab displays the profile with all the associated elements for profile design. A view of Profile 
window is displayed below. 
 

 
 

Fig: 2.13 
 
 
 Under this window the various elements are as follows. 
 

 VIP Properties:   
 
All the properties of Vertical Intersection Points in profile are displayed in this property box. This 
includes the VIP no, RL of designed VIP, and length of curve provided in between the grade lines. To 
magnify a particular Ip, there is a provision of zoom menu at the top right corner of the VIP properties 
box. This will magnify the VIP no. appeared in the property box at the center of the Profile window. 
 

 
 

Fig: 2.14 
 

Zoom Button
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 Options:   
 
The options provide all the supplementary elements required for vertical profile design. This includes 
the scale of drawing, grid and text size that appears in drawing.  
 

 
 

Fig: 2.15 
 
 
3. Cross Section 
 
This tab displays the cross sections drawing in a window named Cross Editor. A view of the cross 
section editor is shown below. 
 

 
 

Fig: 2.16 
 
 The details about the cross editor is given in the procedure section. 
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4. Plan-Profile 
 
This window provides the user to have a look at Plan and Profile at same time. A view of the Plan-
Profile window is displayed below. 
 

 
 

Fig: 2.17 
 
 
 
5. Plan-Profile-Cross Section 
 
This tab displays the plan, profile and cross section in a single window. This allows user to see the 
changes more interactively. Changes in anyone window of the displayed windows is so easy to be 
seen in each window. A view of the Plan-Profile-Cross Section window is as below. 
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Fig: 2.18 
 
 
Besides the Tab/Working Windows, a few buttons can be seen in each working window except the 
cross editor. Below are the buttons which are displayed in each window. 
 

 Update Terrain:   
 

This button is located on the top of the working window. This button enables to get the data for cross-
section and profile from the DTM file made by SW_DTM. Alternatively, this function can also be 
accessed from Utility > Update Terrain. 

 

 
 

Fig: 2.19 
 

Upon clicking the Update Terrain, a window named Profile & Cross-sections is displayed. 
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Fig: 2.20 
 
For a project this window appears only for a single time unless the path of DTM is reset. Generally, 
the Digital Terrain Model is finalized before processing with the SW_Roads. But sometimes it 
becomes necessary to change the DTM file. For this case, the new DTM file is made from the 
SW_DTM. To record the change in the file, the path of DTM must now be changed. This is done 
from Utility > Reset DTM File Path. 
 
The different information to be provided in the Profile & Cross-Sections window are the interval of 
data extraction, extent of data to be taken on either side of the center line and the remarks for the 
drawing. 
 
 Update Design:   
 
This button is used to update the project when any of the design parameter is changed than the 
previously set designed parameters. 
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PROCEDURE:   
 
 
Program Initialization                 
    
Upon double clicking the SW_ROADS_2005.exe, the program will be launched. Before starting to 
work with a project, first a project has to be created. This is done from the file menu with clicking new 
project or if the project has been created earlier then with open project. A pop up window will be 
launched asking whether to work with terrain mode or existing data mode and whether to enter the 
AutoCAD version or not. 
 
 

 
 

 
Fig: 3.1 
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Terrain Mode 
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Terrain Model 
 
Terrain Model is the mode in which data for profile and cross-sections are generated through digital 
terrain model data (prepared by SW_DTM_2005) for surveyed location. Upon starting the 
Sw_Roads_2005 program, a display window asks whether to enter into the terrain mode or into 
existing data mode. To work with the terrain mode, check “Design Using Terrain Model”. 
 

 
 

Fig: 3.2 
 
The software has provision of switching into AutoCAD mode and the SW_Roads mode at any time 
while performing the work. Thus it is not obligatory to enter into the AutoCAD mode at very beginning 
of the project.  Without checking the option will let the program enter into SW_Roads mode.  
 
By clicking “Ok”, the main program window will launch. 
 
 

 
 

Fig: 3.3 
 

The program by default will always open the main window in Plan tab. 
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1. PLAN 
 
Details from Dwg File 
 
The first thing to work with in the terrain mode is to let the program know the drawing which is to be 
taken as reference i.e. backdrop for the alignment (the map prepared from SW_DTM having all the 
required details and contours). By clicking this button, the location of the drawing file will be asked by 
the program.  
 

 
 

Fig: 3.4 
 

By providing the drawing file, a layer selection window displaying the layers of the AutoCAD drawing 
file will be displayed. Select the layers you want to appear in the SW_Roads window and click “Ok”. 
 

 
 

Fig: 3.5 
 

The layers you have selected will appear in the main window of program and the layers name will 
appear in the terrain layers.  The figure below shows the imported layers in the SW_Roads window in 
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which layers Contour, Culvert, House, Index_Contour, Kholsi and Track_2D are imported from the 
AutoCAD. Same layers are displayed under Terrain Layers. User has flexibility to either show the 
particular imported layer in the drawing or not. If a layer is checked, it will appear in the window 
otherwise not. 
 

 
 

Fig: 3.6 
 

 
The solitary purpose of importing the layers is to make a platform on which the alignment can be 
drawn. 
 
 
Draw Alignment 
 
i) Insert Ip 
 
To draw the alignment on the drawing of the main window of the SW_Roads_2005 program, start by 
clicking the insert Ip button located on the top of the SW_Roads window or simply by 
 
pressing “I” key on your keyboard.  Keep inserting the Ip as your desired road alignment follows. 
Figure below illustrates the inserting of Ip to create the alignment. 
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Fig: 3.7 
 
You can insert as many Ip as you want as per your requirement to mark the alignment. It is not 
necessary at this stage to locate the Ip very precisely. You can add, erase or move the Ip later easily.  
 
For inserting a new Ip in between two previously drawn IP’s, first select the Ip after which the required 
Ip is to be placed and then click “Insert Ip”. A cursor having “Insert” appears. Locate the position by 
just clicking on the window where the Ip is desired. 
 
ii) Move Ip 
 
To move the Ip, click the “Move Ip” button located on the top of the SW_Roads window or  
 
simply pressing “M” key on the keyboard. Figure below illustrates the process of moving an Ip. The 
Ip’s are often moved to meet the desired line of alignment. 
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Fig: 3.8 
 

iii) Erase Ip 
  
To erase the Ip, click “Erase Ip” button located on the top of the SW_Roads window or  
 
simply press “E” key of the keyboard. A cursor with “Erase” will be displayed. Select the Ip that is to 
be erased. One Ip is allowed to erase at a time. 
 
Fit Horizontal Curve 
 
After completed with the alignment marking, the next immediate thing to be done is the fixing of 
radius of horizontal curve. The radius of horizontal curve can be given through the Ip property 
window. For this select the Ip in which the curve is to be provided and provide with the radius of 
curve and press enter. 

 
 

Fig: 3.9 
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The curve will be generated as shown in the drawing below.  
 

 
 

Fig: 3.10 
 
When the radius of the curve doesn’t fit in between the lines joining the Ip or overlaps with the curve 
of other Ip, warning sign is displayed in the window in a form of cross marks. For such cases, either 
the user can move the Ip position to accommodate the curve or simply decrease the radius of the 
curve. A sample of curve overlapping is shown below. 
 

 
 

Fig: 3.11 
 

An example of alignment drawing with the radius fitted in every Ip and alignment finalized is shown 
below. 
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Fig: 3.12 
 

 
Once the alignment is finalized, the next step is to define the design parameters. To define the 
design parameters, use Data > Design Data > Parameters. 
 
Design Data 
  

 The various design data to be entered for the design of the road are as follows: 
 

A.  Parameters 
 
The parameter is a sheet where all the data regarding to design is entered. The different elements 
included in the parameter sheet are:  
 
 
1.0) Carriageway: 
      
The parameters associated with the road width are entered in this category. This includes the total 
road width, the desired camber and the camber side.  
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The camber slope is not placed in percentage in the sheet. The above value of 0.03 corresponds to 
3% camber slope. Regarding to the camber side, if a two way camber is desired, “1” is typed in the 
camber side field else “2” is typed to denote the Hill side camber or a single side camber.  
 
2.0) Vertical Alignment Design: 
 
The design elements associated with the vertical alignment design are entered under this category. 
This includes Design speed, Stopping sight distance, Minimum vertical length and Minimum change in 
grade. 
 

 
 
The Design speed is entered as per the class of the road. The Stopping sight distance is given as per 
the calculation by the designer. The minimum vertical curve length is the field in which the limit is set 
to the vertical curve beyond which the length of the vertical curve is not acceptable. When the change 
of grade between two grade lines is small, usually the curves are ignored for such grades. The 
minimum change in grade is the field which lets the program not to place the vertical curve when the 
change in grade between two grade lines is equal to or less than that value. In above example, the 
program will avoid placing the vertical curve till the change in grade is 1.5%. 
 
3.0) Super Elevation Design:                
 
This is the category which incorporates the value related to placement of the super elevation.  
 

 
 
The maximum outer edge slope is the maximum slope given to program for raising the super elevation 
in longitudinal direction. The normal outer edge slope is also to be entered by the designer as per the 
requirement. Super elevations are usually predefined in the form of table. If such values are to be 
given to the program, enter “1” in the super elevation criteria field. This will let the program to read the 
value of super elevation placed in the Data > Design Tables > Superelevation. (Refer Table: 2.1) 

 
One can edit the value of the table. When the value is to be edited enter, simply select the value as in 
Excel sheet and type the desired value. After changing the value of cell hit enter and finally when all 
the edit is finished, press “Save” button before closing it. 
 
When “0” is entered in the Super elevation criteria field, it will let the program to provide the value of 
super elevation as per calculated by the program. 
 



 

  
 

34 

4.0) Extra Widening Design: 
     
The elements of extra widening to be placed in design are entered in this category. 
                   

 
 
The extra widening transition rate is the value to be specified, how the program should place the 
transition for the extra widening. By default it is 0.1m/m. It means that the program would provide the 
transition such that for 1m longitudinal move there will be 0.1m move along the transverse direction.  
 
Fixed transition length is the field to be filled, if transitional rate is not desired but a fixed length of 
transition is desired. 
 
Extra Widening are usually predefined in the form of table. If such values are to be given to the 
program, enter “1” in the Extra Widening Criteria field. This will let the program to read the value of 
extra widening placed in the Data > Design Tables > Extrawidening. (Refer Table: 2.2) 
 
One can edit the value of the table. When the value is to be edited enter, simply select the value as in 
Excel sheet and type the desired value. After changing the value of cell hit enter and finally when all 
the edit is finished, press “Save” button before closing it. 
 
When “0” is entered in the extra widening criteria field, it will let the program to provide the value of 
extra widening as per calculated by the program. 
 
Extra widening placement method is the field to provide the information in which side the program will 
place the extra widening. Entering “0” will let the program to place the extra widening totally inside of 
the curve, “1” will let the program to provide 1/3 of value in the inner side and the remaining to the 
outer side and “2” will let the program to provide totally outside. 
 
Extra widening transition length calculation is the field which lets the program to work either with the 
fixed transitional length as in 4.1 of the table or as per the transition rate as in 4.2. 
 
5.0) Design Overrides for Hill Roads: 
     
Like the minimum vertical length criteria, it is usually desirable to provide the minimum length of 
horizontal curves in super elevation and extra widening for the Hill roads.  

 

 
 
6.0) Right of Way: 
 
This field is to be provided with the right of way as per the type and class of the road. 
 

 
 
8.0) Starting Chainage: 
  
Sometimes, it is desirable that the starting chainage of the alignment be started from other value than 
0. The desired starting chainage is entered in this field. 
 



 

  
 

35 

 
 
After entering all the design data, the data in the sheet are saved by clicking the save button. 
 

B.  Hill Side Data 
 
Hillside data provides the program with the information in which side of the road does the hill lies. The 
code represents the side. This is a compulsory field to be filled in case when the camber is to be 
provided at the hill side i.e. One Sided Camber. 
 

 
 

Table no: 3.1 
 

If the hill side is on the right side of the alignment, enter “1” in the SD Code field or “2” if the hill side is 
on the left side of the alignment. Click the “Save” button to record changes made in the table before 
closing the table. 
 
When the data for Hill Side is required to be imported from the excel sheet, click “Import”. The range 
of the data in excel sheet should be selected prior of clicking the import button. Similarly, the data of 
the Hill Side table can be exported to excel or notepad as desired.  
 
C.  Side of Extra Widening 
 
Side of extra widening is the provision of mode of placement of extra widening to the horizontal curves 
according to the radius of curve. The percentage value is assigned to the value of extra widening to 
place on either inner side of the horizontal curve or the outer.  
 

 
 

Table no: 3.2 
 

One can edit the percentage value or add another set of values as per required. Click the “Save” 
button to record changes made in the table before closing the table. 
 
When the data for side of extra widening is required to be imported from the excel sheet, click 
“Import”. The range of the data in excel sheet should be selected prior of clicking the import button. 
Similarly, the data of the side of extra widening table can be exported to excel or notepad as desired. 
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D.  Soil Type 
 
Soil type according to the chainage is defined in this field. Prior to defining the chainage, soil code has 

to be generated. This can be done by clicking   on the right corner of the soil type allocation table.  
 

 

 
 

Table no: 3.3 
 
You can define as many types of soil as your need in the project. Soil codes are the abbreviated form 
of the soil types defined in a manner that, when needed, they can be called by their abbreviated form. 
Suppose one of the types of soil is ordinary soil. Let the code be “OS” then type “OS” in the Soil Type 
(Code) field. Elaborate the actual meaning of code in the soil type field. The cut and fill slopes and the 
foundation cut slopes are defined next for the defined type of soil. After finishing with defining the soil 
type click “Update Code”. If you have earlier made the code in excel file, you can import it by clicking 

“Import Code”. Export of code is also facilitated. After generation the Soil type codes click    to 
return to the Soil type allocation table. Now the soil type is listed in pull down menu under “Soil Type 
(Code)”. You can now specify the chainage range and the type of the soil. 
 

 

 
 

 
Table no: 3.4 

 
If previously defined Soil type is to be imported from the Excel file, click “Import”. The export of the soil 
type data is also facilitated by the program. After defining the soil type, click “Save” before closing.  
 
E)  User Chainage 
 
It is desirable often to include chainages of special interest in the cross section. Such chainages with 
special remarks are included under user chainage which have not previously taken under 
consideration. 
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Table no: 3.5 
 

In the above table, it is desired to incorporate the remarks for chainages 0+830.000 and 1+130.000. 
Click the “Save” button to record changes made in the table before closing the table. 
 
When the data for User Chainage is required to be imported from the excel sheet, click “Import”. The 
range of the data in excel sheet should be selected prior of clicking the import button. Similarly, the 
data of the User Chainage table can be exported to excel or notepad as desired. 
 
F)  Shoulder Data 
 
This table is used for providing the shoulder data for the road. The shoulder data include width and 
thickness for the desired chainage interval. Click the “Save” button to record changes made in the 
table before closing the table. 
 

 
 

Table no: 3.6 
 

When the Shoulder Data is required to be imported from the excel sheet, click “Import”. The range of 
the data in excel sheet should be selected prior of clicking the import button. Similarly, the data of the 
Shoulder Data table can be exported to excel or notepad as desired. 
 
G)  Pavement Data 
 
The thickness of the pavement is given in this table. Though the thickness of pavement is uniform for 
entire reach of road, sometimes it is desirable to have varying pavement thickness in terms of 
chainage interval. Click the “Save” button to record changes made in the table before closing the 
table.  

 
 

Table no: 3.7 
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When the Pavement Data is required to be imported from the excel sheet, click “Import”. The range of 
the data in excel sheet should be selected prior of clicking the import button. Similarly, the data of the 
Pavement Data table can be exported to excel or notepad as desired. 
 
H)  Variable Road Width 
 
When the variable width of the road is required, this table is used. The variable road width table 
includes the range of chainage and the road width on either side of center line of the road. Click the 
“Save” button to record changes made in the table before closing the table.  
 

 
 

Table no: 3.8 
 
 

When the data of Variable Road Width is required to be imported from the excel sheet, click “Import”. 
The range of the data in excel sheet should be selected prior of clicking the import button. Similarly, 
the data of the Variable Road Width table can be exported to excel or notepad as desired. 
 
I)  Pass-By 
 
For providing the pass-by at different chainages for smooth vehicle movement, data is entered in this 
table. This includes the chainage at which the pass by is to be provided, the length of the pass by and 
its width on right or left side of the road along with the transitional length. Click the “Save” button to 
record changes made in the table before closing the table. 
 

 
 

Table no: 3.9 
 

 
When the data of Pass-By is required to be imported from the excel sheet, click “Import”. The range 
of the data in excel sheet should be selected prior of clicking the import button. Similarly, the data of 
the Pass-By table can be exported to excel or notepad as desired. 
 
Finishing with the all the details of alignment, the next thing are to work out for Profile and Cross 
Sections. To generate the data of profile and cross-sections click “Update Terrain” located on the mid 
top of the SW_Roads window. Upon clicking this button, a screen called as profile and cross-section 
appears. 
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Fig: 3.13 
 

The interval is the field to be defined in what interval the program has to extract the data of cross 
section. The Interval for the data extraction can be given according to the site condition. The left and 
the right distance are specified for obtaining the extent of data on the left and right side of the road. 
 
The option of “Include Curve BC, MC & EC” allows the program to generate the cross section data 
for the beginning, mid and end of the horizontal curves whereas “Include User’s Chainage” allows 
the program to generate the cross section data for the user chainage defined in Data > Design Data 
> User Chainage. For obtaining the remarks for the cross section click on “Remarks from Dwg File”. 
This will ask the location of the drawing file from which the alignment has been started to work with. 
 

 
 

Fig: 3.14 
 
 

When the drawing file location is provided, a window will appear which allows user to click on the 
layers that are required for appearing in cross-section. 
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Fig: 3.15 
 

Click for the layers which are required for the cross section drawing and then click “Ok”. The window 
named “Profile & Cross Sections” now appears as below. 
 

 
 

Fig: 3.16 
 

The layers selected are displayed on the right which can still be unchecked if required. Now click “Get 
DTM”. This will ask the user to locate the previously made DTM file through SW_DTM. 
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Fig: 3.17 
 

Click on the correct DTM file for the drawing and press “Open”. Now click “Ok” to generate the cross 
section and profile. 
 

Now, if the profile tab or cross section tab is viewed, the program will display the generated Profile 
and Cross Section from the terrain. 
 

Reset DTM Path 
 
Usually the DTM file is made only after the final output of the contour map. And hence we do not 
change the DTM file again and again in a project. But sometimes it happens that certain error is found 
in the contour map and the process of contour making is to be repeated. For such condition it is not 
always desirable to make new project and work again. For such cases, if a new DTM file is made, the 
user should click Utility > Reset DTM Path to mark that the DTM file has been changed. Now if 
“Update Terrain” button is clicked, the program will ask for the new DTM file location and the same 
procedure is followed as described before. 
 
If Utility > Reset DTM Path is not clicked, and the “Update Terrain” button is clicked, the program 
will simply update the terrain but wouldn’t ask for the DTM file for Profile and Cross Section 
generation. 
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2. PROFILE 
  
After updating terrain by clicking “Update Terrain” button, data for profile is generated. You can check 
it out from the “Existing Profile” in the data menu for the generated data. The drawing for profile can 
be seen on the screen switching to the Profile tab as below. 
 

 
 

Fig: 3.18 
 
Reduced levels are marked at the interval of 5m on the side bars. Bottom box will shows the existing 
level at every interval of chainage that you have generated using DTM file.  

 
 
 
 
User can show or hide the format box by checking on the “Format” check box 
provided at the right side of the screen. 
 
The grid can also be shown or hidden by clicking “Grid” check box. Grid lines 
can be drawn at desired intervals for both vertical and horizontal axes. 
Change the values in the “Level” and “Distance” text boxes for the respective 
axes. 
 
Further, scale for both the vertical and horizontal axes can be changed 
according to ease of working during design. This is done from “Ver Scale” and 
“Hor Scale” respectively.  
 
Changing the values in “Text Height” box will effect on the size of the text 
indicating grade values of the design profile line. 
 
 “Refresh Drawing” button will regenerate all the drawings on the screen. 

Zoom Button
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Draw Design Profile 
 
i) Insert VIP 
 

To draw the design profile, start by clicking insert VIp button located on the top of the 
window or simply by pressing “I” key on your keyboard as in case of alignment. Figure below 
illustrates the inserting of VIp to create the design profile. 
 

 
 

Fig: 3.19 
 

User can insert as many VIp as per requirement to mark the Design Profile. It is not necessary at this 
stage to locate the VIp very precisely. You can add, erase or move the VIp later easily.  
 

ii) Move VIp 
 

To move VIp, click the “Move VIp” button located on the top of the window or simply 
pressing “M” key on the keyboard. Figure below illustrates the process of moving a VIp. 
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Fig: 3.20 
 
iii) Erase VIp 
  

To erase the VIp, click “Erase VIp” button located on the top the window or simply press “E” 
key of the keyboard. A cursor with “Erase” will be displayed. Select the VIp that is to be erased. One 
VIp is allowed to erase at a time. 
 
 

Fit Vertical Curve 
 

The next immediate thing to be done is the fixing of length of vertical curve. Though SW_Roads 
provide default calculated length of curve for each Vip, you can change its length as per your 
requirements. It can be given through the VIp property window. 
 

 
 

Fig: 3.21 
 

For this select the VIp in which the curve is to be provided and give the length of curve in LOC field 
and press enter. Click on zoom button to make a focus on your selected VIp.  
 
If the curve doesn’t fit in between two VIp (overlapping of two curves), warning sign is displayed in the 
window with a red cross mark. A sample of vertical curve overlap is shown below. 
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Fig: 3.22 
 
 
To correct such situation, either you can move the VIp to accommodate the curve or simply reduce 
the length of the curve. 
 

Once the Design profile is finalized, the next step is to update the design that will update your cross 
section with design levels. Click “Update Design” button to update your design data. 
 
 
3. CROSS SECTIONS 
 
When the Cross-section tab on the bottom left of the main screen of SW_Roads_2005 is clicked 
screen of Cross-Section appears as shown below with a name of Cross Editor. 
           

 
 

Fig: 3.23 
 



 

  
 

46 

The commands available in the Cross-Section Editor are as follows: 
 

 Utility: 
 
Under this menu, the different sub-menus are as follows: 
 

 
 

Fig: 3.24 
 

1. Save Cross and Update Plan: 
 
This allows the user to update the plan and save the works done on cross sections. This function is 
also facilitated by the keyboard shortcut Ctrl+S. 
 
2. Update Terrain: 
 
This facilitates to update terrain if required. When the DTM path is reset and processed, the terrain 
should be updated. 
 
3. Add Drains: 
 
The drains when are to be applied in certain reach or throughout the sections, this is used. The pop 
up dialog box will ask for the chainage from which the drains is to be applied, side of road on which 
drain is to be placed, and the type of drain. One can select the types of drain from the pull menu under 
“Select Structure to ADD”. 
 

 
 

Fig: 3.25 
 
4. Find/Replace Structure: 
 
When once applied structures to the cross-sections have to be replaced by the other type of structure, 
this sub-menu is used.  
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Fig: 3.26 
5. Always on Top: 
 
This enables the cross-editor to stay on top of all windows application. 
 

 Output: 
 
This is the menu which allows to extract the data from the cross editor to the Excel files. The different 
sub-menus under this are as follows: 
 
1. Slope Length of Cut Fill Line: 
 
When the slope length of the cut and fill lines are desired, this sub menu is clicked. Doing so will ask 
for the location on your computer where it should save the excel format file. 
 
2. Quantities: 
This sub menu is for dumping the quantities in excel. This includes the quantities of earthworks, 
quantities of drains; quantities of different structures in different tab of excel etc. Clicking this sub 
menu will ask the location on your computer where it should save the excel format file. 
  

 Drawing: 
 
This menu helps to obtain the works of cross editor in AutoCAD file. The different sub menu under this 
menu is as follows: 
 
1. Draw Current: 
 
This enables drawing the current cross section on the cross editor window in the AutoCAD. Clicking 
this will ask for the scale in which the drawing is required in the AutoCAD. Detail of this is discussed in 
Chapter IV. 
 
2. Draw ALL: 
 
This is the sub-menu which will draw the entire cross sections as seen in the cross-editor to the 
AutoCAD. By clicking this sub menu will ask the scale to which the drawings are to be drawn, format 
(i.e. no. of rows and columns) in which drawings are required, whether to include all the cross sections 
or the cross sections at fixed interval, write the area on the cross section etc. Detail of this is also 
described in Chapter IV. 
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The different features available in the Cross-Section Editor are as follows: 
 

• Add button 
• Replace button 
• Insert button 
• Delete button 
• Previous and Next Buttons  
• Copy from Previous and Copy from Next Buttons 
• Roadside Items 
• Chainage and Cross-Section No. 
• Shift Center Line by 
• Input data 
• Area calculation: 
• Structures 
• Make Default Structure 
• Different Zoom Functions 
 

 The various functions of the Cross-section are defined below: 
   

 Delete commands allows the user to remove the 
unnecessary structures. Highlight the component 

that has to be removed and click   command. 
 

 Replace command allows replacing the 
structure. Pick the structure from the menu as 
shown in the figure and also highlight the 
structure to be replaced and click the button.  
 

 Insert command allows the user to insert the 
structures. A Gabion Retaining Wall of Type A is 
inserted in the figure. Location of the structure to 
be inserted is given by clicking preceding items.  

 

 
 
Add allows the user to add structures in the 
roadside. Required structure can be selected 
from the pull down menu as shown in figure.  
                              
 

 

 
 

 
Previous and Next Buttons: 
 

 Previous command allows viewing the immediate previous cross-section. 
 
  Next command takes to the new cross-section. 

                               
Copy Previous and Copy Next: 
 

     If structures for the cross-section required is similar to the structure of the previous  
     cross section then it can be provided by clicking the command Copy Previous. 

      
     If structures for the cross-section required is similar to the structure of the next   
     cross-section then  it can be provided by clicking the command Copy Next. 
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 Roadside items: 
 
In cross section drawing, the various structures or items of 
the road can be placed, edited and edited. For ease, the 
center line of the road divides the whole cross editor into 
two halves. To edit the road side elements on each of 
side, select the list from the respective side. Data of the 
cross-section appeared in screen is shown as road items 
with respect to the centre line.  

 
 
The Roadside items are defined below: 
 
In default mode of cross-section, the left side road items and right side road items are given in the 
screen. In both sides of road items, centre line, shoulder and cut fill line are given. When the user 
highlights an item then program will provide the properties of the item selected. When selected, a 
cyan color is seen for the clicked parameter. Some of the frequently occurring roadside items are 
described below. 
 
Cut and Fill Line (CFLIN): 
 
The cut fill line is represented by abbreviation CFLIN in the program. The 
cutting and the filling slope is the main property displayed in the display 
window. One can edit the cut and fill slopes as per the demand of the 
cross section, the initial value being the one provided through soil types in 
the main data from Data > Design Data > Soil Type. The various property 
displayed in cut fill line is as shown. The slope length, Partial Dist., RL that 
are shaded are not allowed to change. 
 
Carriageway: 
 
The centerline of the road is represented by CENTR in the program. 
Clicking this will show the details of the carriageway property of the 
respective clicked side of the road. As all the values are shaded, it informs 
the user that none of the field can be edited in this category. 
 
Shoulder: 
 
The shoulder on each side of the road is represented by SHLUD in the 
program. Clicking this will show the properties of shoulder that are 
provided through design data.  
 
 
Chainage and Cross-Section no. and Shifting Centerline in Plan 
 
 
Chainage: 
 
This field shows the chainage at which the cross section is displayed by the cross editor. It is also 
useful for viewing the cross section of desired chainage. For this simply type the chainage at which 
cross section is desired and press enter. The cross editor will show you the cross section for the 
chainage you have typed. 
 
Cross-Section No.: 
 
This field shows the cross section number in terms of total cross sections. This also serves as method 
of jumping to the desired cross section. Simply provide the no. of cross section to be viewed and 
press enter. The cross editor will show you the cross section for the cross section no. you have typed. 
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Shifting Centerline in Plan:  
 
Shifting of centerline may be required by viewing cross sections. This may be required due to mass 
balance reason or some specific reason. When centerline is to be shifted, click the arrow button to 
move the centerline either on left or right direction whichever is required. As the arrow is clicked, the 
value to which centerline is shifted is shown in the box. Alternatively, simply type the amount by which 
the cross section is to be shifted in the box and press enter. Note that the value is in negative terms 
for left side of the road and positive for the right side. 
 
After shifting the cross section, press “Show Marks” button to see the effect of particular shifting of 
centerline in the plan. This button will place a cross mark in the plan that would be helpful to judge if 
the shifting of alignment is justified or not. 
 
Area calculation: 
 

For the ease in visual judgment, the program has provisions to show area of cut, 
fill, structure cut, back fill or all combined in graphical form. After placing the 
structures and cut fill lines, the area is found by clicking “Calculate Area” button 
located on the left side of cross editor. The desired area i.e. cut, fill, structure cut, 
back fill or all combined is then checked to have graphical look in the cross editor. 
The value is displayed at the same window.  A sample of the graphical display is 
as below. 
 

 
 

         Fig: 3.27 
 
Color Coding: 
 
The different colors used in the program for representing the area in cross editor are as follows: 
 
a) Light Brown 
 This color represents the cut area in the cross section. 
 
b) Yellow 
 This color represents the structure cut area in the cross section. 
c) Light Green 
 This color represents the fill area in the cross section. 
 
d) White 
 This is the color to represent the backfill. 
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View Options: 
 
The view options for the cross editor is located on the upper right corner of the cross editor. Originally, 
the cross section is always viewed with Zoom Extents.  
 
To magnify the cross section, click on zoom-in (+) and use zoom-out (-) to reduce the magnification. 
To pan the cross sections use the pan button. Incase, to view a certain portion of the selected cross 
section click on zoom window button and then click and drag with the left mouse button pressed on, 
for a rectangular window covering the portion to view. Release the mouse button, to view the portion 
of the selected Cross Section. 
 
Structures: 
 
The different structures acquired by the program can be added according to the 
requirement. Different types of retaining structures, Drain, Pass By, GW and 
many more other structures can be accrue from the combo box as shown in 
figure. When a project is formed, the program by default makes a folder named 
“Structures” in the project folder. All the properties of the individual structures 
can be found in that folder.  
 
All the structure”s parameter has a default value assigned by the program. One can change the 

values of parameters by directly editing in the property box for individual cross section or 
for all cross sections. Whenever the structure is desired to be changed for entire project 
there is a button called “Make Default Structure” which sets the value of the entered 
parameter for the rest cross sections. For example, If the hill side height of the DrainA is 
changed to 0.5 and the button “Make Default Structure” is pressed, for the sections 

onward, if DrainA is chosen, the value of hill side height is always 0.5 for the entire project. 
 
The different abbreviated forms of the structures are as follows: 
 

1. CFLIN   Cut Fill Line 
2. ExtCW  Extra Carriageway 
3. EXCFL  Extra Cut Fill Line 
4. BKFL0  Back Fill Line Type 0 
5. BLFL1   Back Fill Line Type 1 
6. PASSB  Pass By 
7. SHLUD  Shoulder 
8. EXSHO  Extra Shoulder 
9. EXTLO  Extension Line 
10. DrainA  Drain Type A 
11. DrainB  Drain Type B 
12. DrainC  Drain Type C 
13. DrainD  Drain Type D 
14. DrainE  Drain Type E 
15. DrainH  Drain Type H 
16. MwRetA  Masonry Retaining Wall Type A 
17. MwRetB  Masonry Retaining Wall Type B 
18. GwRetA  Gabion Retaining Wall Type A 
19. GwRetB  Gabion Retaining Wall Type B 
20. GwRetC  Gabion Retaining Wall Type C 
21. MwBrtA  Masonry Breast Wall Type A 
22. MwBrtB  Masonry Breast Wall Type B 
23. GwBrtA  Gabion Breast Wall Type A 
24. GwBrtB  Gabion Breast Wall Type B 
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25. DrRetA  Dry Retaining Wall Type A 
26. DrRetB  Dry Retaining Wall Type B 
27. MxRetA  Mixed Retaining Wall Type A 
28. MxRetB  Mixed Retaining Wall Type B 

 
Note: The Mixed Retaining wall is a composite type of wall in which gabion wall is embedded in the 
masonry wall. 
 
Drains: 
 

There are altogether five different types of drains defined in the 
program. User can choose the type as per their project 
requirement and adjust the dimensions. The provision of drains 
can be made per cross section basis as by adding the required 
drain to the cross section or provide the drains chainage wise. 
When drain is to be provided through entire reach or in the 
range of desired chainage, the placement is done from Utility > 
Add Drains. The adjoining picture clearly shows how the drain 

can be placed in a certain range of chainage.  
 
Drain Details 
 
The drain can be added as other structures from the structure pull 
down menu. The drains can be added, replaced with other structure or 
drain itself, deleted as required. 
   
A sample property window of the Drain Type A inserted is shown in the 
adjoining picture.  Except the roadside top level and invert level, all the 
other properties of the drain can be changed. 
                                                               
While changing drain type or its position or removing / adding drain, the 
cut area, the fill area, and other various parameters will also change 
which can be seen in the screen at the same time. 
 
Wall Details 
 
Whenever retaining walls or breast walls be required in the cross 
section, simply click on the pull down menu of structure list and select 
the type of wall desired. The wall can be replaced, deleted, and added 
as per the requirement. 
 
A sample property window of the Gabion Retaining Wall Type A inserted 
is shown in the adjoining picture.  Except the top level, all the other 
properties of the drain can be changed. One can change the height of 
the wall by increasing the value in “Gabion Layer Count” parameter. The 
values in Box”n” parameter corresponds to: Height | Width | Inside offset 
distance. 
While changing type of retaining wall or its height or its position or removing / adding retaining wall, 
the cut area and the fill area for earthwork as well as the cut area for structure will also change which 
can be seen in the interactive screen. 
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EDIT SUPER ELEVATION: 
 
Super Elevation is calculated by the software using the Design Data located at Data > Design Data > 
Parameters and Super Elevation Table Data > Design Tables > Super Elevation. Super Elevation is 
provided as per value defined for range of Radius in the table. The calculated value for super 
elevation will be tabulated in the grid view both in IP wise and Chainage wise. Edit > Super 
Elevation. 
 
In the case of “Terrain Mode”, calculation is performed only after finalizing alignment and terrain is 
updated by clicking “Update Terrain” button. While in “Exiting Data Mode” calculation is performed by 
clicking “Recalculate Superelevation” menu. Then the checkbox whether to show super elevation 
graphically on plan or not is enabled. 
 

 
 

Table no: 3.10 
 

SW_ROAD has the provision for the grouping of IP for same super elevation. If certain IPs are to be 
assigned with same value of super elevation without transition between them, groping of IP is needed. 
To group IPs just click on “From” column, a combo box will appear with the list of IPs, select the 
starting IP for group and click on “To” column to select the last IP of the group. If regrouping is needed 
then “Reset” button can be clicked which will erase the entire group. When done click on “Group” 
button. Now if you change the value for any grouped IP, same value will be assigned to all IPs in that 
group. This time the software won’t handle the overlapping case. It just shows the overlap with “Red” 
mark on the cell and user is let to change the value to handle this case. 
 
“Re-Calculate” button will let the software to calculate for the super elevation. One should keep in 
mind that this button will replace all the changes made by the user. So once the changes are made 
according to your requirement, do not click on this button. This button does the same calculation as 
“Utility> Recalculate Super Elevation” menu does. 
 
“Save” button is to be clicked to save the values that the user has changed as per his requirement. 
After making required changes do not forget to save the changes which will update the calculations for 
Chainage view. 
 
“<--” button will let user to move to previous cell from the selected cell. 
 
“-->“ button will let user to move to next cell from the selected cell. 
 
“View Ch” button will show the values of super elevation in Chainage wise. See figure below. 
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Table no: 3.11 
 

The four columns named “CH from”, “CH To”, “SE From” and “SE To” represents to as its name. The 
value “100” represents for the normal camber in the case of both side camber as defined in Design 
Data. The value will be its respective super elevation value in the case of Hill Side camber. For 
example; in the first row, from chainage 0+000.00 the super elevation starts with normal camber (100) 
and ends at change 0+011.210 with normal camber. This means throughout this chainage normal 
camber is provided. In the case of second row, super elevation starts with normal camber from 
0+011.210 and ends with super elevation of -7 at 0+038.710. This means throughout this length 
transition occurs from normal camber to -7. 
 
There is a “warning Label” indicating “Editing SE by chainage will delete grouping of IP”. This 
means whenever you edit the values for the super elevation with chainage wise the grouping of IP (if it 
exist) will be deleted because the change made in super elevation with respect to chainage may 
create redundancies during calculation as chainage can be given to any range. 
 
“Save” button is to be clicked to save the changes that user has made. 
 
“View IP” button will let user to view the super elevation values in IP-wise. 
 
“Reset” button will undo the changes made by the user. 
 
“Close” button will let user to exit. 
 
These super elevation values can be seen graphically in plan. 
 
 
Edit Extra Widening 
 
Edit in Table Format 
 
SW_ROAD calculate extra widening itself for each radius according to the range value for radius 
tabulated in the Extra Widening table and the side of extra widening is decided as in the Side of 
Extra Widening table. This calculated extra widening can be viewed from Edit > Extra Widening. 
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In the case of Terrain Mode the value is calculated only after the alignment is fixed and terrain is 
updated by clicking “Update Terrain” button. And in the case of Existing Data Mode, Recalculate 
Extra widening menu should be click to calculate it. Then the checkbox whether to show extra 
widening graphically or not is enabled. 
 

 
 

Table no: 3.12 
 

If any changes are to be made with the values of the extra widening provided then it can be done by 
simply type the values in the respective field and save the changes by clicking on “Save” button. 
The values in the table for extra widening are in meters. The rate is in percentage value and the 
placement should be the number code indicating “0” for totally inside, “1” for 1/3 inside, “2” for totally 
outside. 
 
If user wants to import the extra widening values for each Ip from Excel then it can be done by 
selection the proper range in Excel and clicking in “Import” button. The range should of 6 columns as 
shown in above figure.  
 
The Extra widening values shown in this grid view can also be exported either in text file or in CSV 
format. Just click on “Export” button which will pop up with dialog box. Give the file name select the 
desire format and click “Save”. 
 
 
Edit in Interactive Window 
 

 
Extra Widening can also be changed to desired value of designer in plan 
view tab. There is a frame at the right side of the plan view window in which 
extra widening values are shown with respect to the selected IP. Here the 
values for extra widening can be changed with the required one. The figure 
below shows the field to change for extra widening on left or right side. The 
placement for extra widening can also be change different to that of 
calculated by the software which may either be “Totally inside”, “1/3 
inside”, or “Totally Outside”. The extra widening rate can also be edited 
which is in percentage value. 
 
The changes made on this property window can be seen graphically in plan 
if extra widening check box is true. 
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ROAD ELEMENTS 
 
The different road elements associated with the drawing are enlisted under “Road Elements”. These 
elements are provided in the form of check boxes which when checked will display the checked 
element in the plan tab/working screen.   

 
“Chainage” when checked, will display the chainage value in the plan. The 
interval of chainage display can be changed from Data > Options. 
 
“Road width” ” when checked, will display the road with in the plan along the 
center line of alignment.  
 
“Extra Widening” when checked, will display the extra widening following 
with road width in the plan. 

 
“Pass By” will make visible if pass by exist. 
 
“Super Elevation” shows the values of super elevation in the plan. 
 
“Staking” will display the cut-fill area, retaining structures, drains and wall detailing etc.  
 
A sample with all the road elements is shown below. 
 

 
 

Fig: 3.28 
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EXISTING DATA MODE 
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Existing Data Mode 
 
Existing Data Mode, in contrast to the Terrain Mode, data for Alignment, profile and cross-sections are 
entered either by typing directly to the respective property dialog box or importing from Excel sheet. 
Upon starting the Sw_Roads_2005 program, a display window asks with two options; the terrain mode 
and the existing data mode. Click the Existing data mode.  
 
The AutoCAD Version Option will let you to work in companion with AutoCAD as previously described 
in Terrain Mode Section. 

 

 
 

Fig: 3.29 
Click “OK” to launch the main program. 
 
1. PLAN 
 
Draw Alignment 
 

It is assumed in this mode that you have the data from your field survey for the alignment. Click Data 
> Alignment. An alignment property dialog box appears as follows; 
 

 
 

Table no: 3.13 
 

Now either enter the data obtained from the field manually, or click “Import” to import the data from 
Excel file.  
 
Importing Alignment Data from Excel File 
 
For importing the alignment data from the Excel file, select the range of your Alignment data as shown 
in the figure below. 
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Fig: 3.30 
 

Activate the Alignment Property window and click on “Import”. The data you have selected will be 
imported. This may take some time if you have a large number of data. After importing data, click on 
“Save” button which will save your data, and the alignment will be drawn in the plan tab. A view of 
imported data is shown below. 
 

 
 

Table no: 3.14 
 

 
Re-numbering IP 
 

Sometimes it is desired that the Ip no. be in sequential order rather than different no. as obtained from 
the field. For renumbering the Ip no., click on “Re-number IP” button. Clicking so will ask you to 
provide with the initial no. of Ip that you wish to appear in the program in a form of input box.  
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Fig: 3.31 
 

 
Exporting Alignment Data 
 

SW_Road_2005 has a provision of exporting your alignment data too. Click on “Export” button that 
pops up with a dialog box as follows. Locate where you want to keep you file, type the file name, 
select your desired file format either text file (*.txt) or Comma Delimited File (*.CSV) and click on 
“Save” button.  
 

 
 

Fig: 3.32 
 

Editing of IP data 
 

In Existing Data Mode, interactive editing of Ip’s is disabled. This is disabled for the reason that when 
alignment is altered, all the parameters of the design are changed, which is not desired in case of 
Existing Data Mode.  
 

Working with Plan 
 

Refer to Terrain Mode of Design. 
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2. PROFILE 
 
Profile data is to be either imported or entered manually similar as the Alignment. Once you import 
your data, click on “Save” button to save your data. The drawing for exiting profile is shown on the 
window in Profile tab as in the case of Terrain Mode. The data of the existing profile cannot be edited 
in the drawing. If the data editing is required, edit the data from Data > Existing Profile. 
 
Designing Profile 
 
The design principle and methodology for the profile is same for the Terrain Mode and Existing Data 
Mode. Refer to the design of Profile in Terrain Mode. 
 
 
 
3. CROSS-SECTION 
 
Data for cross section is either imported or entered manually as in the case of alignment. The data for 
cross sections are imported or accessed from Data > Cross Section. 
 

 
 

Table no: 3.15 
 
Importing Cross-Section Data: 
  
Select the proper range as shown in fig below in the Excel sheet and click on “Import” button. The 
imported data will be shown in grid view one chainage at a time.  
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Fig: 3.33 
 
The data when imported will be as follows. 
 

 
 

Table no: 3.16 
 
Exporting Cross-Section Data: 
 
Export your cross section data either in text format or in CSV format and save in your desired location. 
Refer to Exporting Alignment Data section. 

 
 
“Go To” button will let you to show the sectional data in grid view at you type 
chainage in the text box near to this button. 
 
“<< -- First” button will let you to go to sectional data of the starting chainage. 
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“Last -- >>“ button will let you to go to the sectional data of the last chainage. 
 
“< -- Back” button will let you to view the sectional data a step back from the current data showing. 
 
“Next -- >>“ button will let you to view the sectional data a step forward from the current data showing. 
 
“Save” button will let you to save your imported data as well as any change you made in the data. 
 
“Cancel” button will let you to exit. 
 
“Preview” button will let you to see the drawing of exiting ground level at its respective cross section 
as in the figure below. 
 

 
 

Fig: 3.34 
 

If a new cross section is to be inserted after having your data imported, click on 
“Insert New” button which will let you to type your data for new chainage. The 
chainage will be automatically displayed at the interval of 10m. If this is not your 
required chainage then you can change it. When you type your data, you will be 
shown with its drawing in the preview window. 
 
If you need a data for a chainage between two existing chainage then you can 

interpolate the data for it. Just click on the “Insert Interpolated” button which will pop up with an input 
box asking for the chainage. Give the required chainage and click “OK”. The data will be interpolated 
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but not the remarks. If remarks are also desired, user can type it in the remarks column at required 
partial distance. 
 
If you need to delete a cross-section data of certain chainage then make that chainage section a 
current view by typing the chainage on the text box and clicking “Go To” button. Click on “Delete X-
Section” button and the current cross-section data will be erased. To record changes in data click on 
“Save”. 
 
Cross section Editor 
 
The working principle and methodology with the cross section editor is same as that of the Terrain 
mode. 



 

  
 

 

 
 
 
 
 
 

CHAPTER-IV 

 

OUTPUTS   

(Data & Drawings)   
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OUTPUTS:                                                                   
 
The outputs of the program can be categorized into two types according to the format of output. 
 
1) Data 
 
All the data are obtained in the Excel.  Horizontal Curve Data, Vertical Curve Data, Property Line Co-
ordinates, Layout Data and Quantity are the elements that can be obtained in this file system. This is 
obtained from Outputs > Horizontal Curve Data / Vertical Curve Data / Property Line Co-
ordinates / Generate Layout / Quantity. 
 
2) Drawings  
 
All the final drawings are obtained in the AutoCAD. The final alignment including staking lines, Profile 
and Cross-sections are obtained in the AutoCAD which are in ready to print format. This is done from 
Drawings > Alignment / Profile / Cross-sections. 
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1) Data 
 
All the data obtained from the program are in the excel file i.e. *.xls format. These data are in the 
ready to print format. All the output data are obtained from Output > menu of the main SW_Roads 
Program.  
 

 
 

Fig: 4.1 
 
A) Horizontal Curve Data 
 
When the horizontal curve data is required, click Output > Horizontal Curve Data. This will ask the 
user to provide with the location on which the data for horizontal curve is to be saved in excel file 
format.. 
 

 
 

Fig: 4.2 
 

By clicking the “Save” button, the program will save all the elements of horizontal curve in the excel 
file. A sample of such data is shown below. 
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Table No. 4.1 

B) Vertical Curve Data 
 
When the vertical curve data is required, click Output > Vertical Curve Data. This will ask the user to 
provide with the location on which the data for horizontal curve is to be saved in excel file as in the 
case of Horizontal Curve Data. 
 
By saving the in excel file, the program will save all the elements of vertical curve in the excel file. A 
sample of such data is shown below. 
 

 
 

Table No. 4.2 
 
C) Property Line Coordinates 
 
This will generate property line coordinates. As in the case of Horizontal and Vertical Curve Data, in 
this also the program will ask for the location on which the data of property line coordinates are to be 
saved in excel file. 
 
By saving the data in excel file, the program will save all the elements of property line coordinates in 
the excel file. A sample of such data is shown below. 
 

 
 

Table No. 4.3 
 

D) Generate Layout 
 
The layout data are obtained from here. The layout data generation has flexibility for the users. Users 
can define the interval in which the data for layout is to be generated. When clicked, the program will 
ask the user to provide the interval. 
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Fig: 4.3 
 
As in the case of above outputs, the program will ask for the location on which the layout is to be 
saved in excel file. 
 
By saving the data in excel file, the program will save all the elements of the layout in the excel file. A 
sample of such data is shown below. 
 

 
 

Table No. 4.4 
 

E) Quantities 
 
For the Quantities, when the sub-menu is clicked, the program will automatically open the cross 
editor. The quantities of the Earthwork, Structures, Pavement, Shoulder and Drains are obtained from 
the cross editor. 
 

 
 

Fig: 4.4 
 

The SW_Roads_2005 has provision for breaking the elements of cut and fill for different structures 
and presenting in different tabs of excel file. This makes the work more simplified and easier.  
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Fig: 4.5 
 

 
2. Drawings 
 
All the drawings are obtained in the AutoCAD format files (*.dwg). These drawings are in the ready to 
print format. All the drawings are obtained from Drawings > menu of the main SW_Roads Program. 
 

 
 

Fig: 4.6 
 
A) Alignment 
 
The alignment drawing is required, click on Drawing > Alignment. Before processing with the 
drawing for the alignment make sure that you have clicked on the different road elements which are 
desired in the final alignment drawings. The elements for the alignment drawings are in the “Plan tab” 
under “Road Elements”. 
 

 
 

Fig: 4.7 
 

The elements checked in the road elements will only be drawn in the AutoCAD. So make sure about 
the things that you desire to obtain in the AutoCAD drawing. When the alignment is clicked, the 
program will ask about the certainty about drawing. 

 

 
 

Fig: 4.8 
 

Click “Yes” to draw. If AutoCAD is not previously launched, the program will automatically launch the 
AutoCAD and makes the drawing in original coordinates. If AutoCAD is open, make sure that the 
window in which you are about to draw the alignment is active. The program will draw in the AutoCAD 
window which is active. 
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B) Profile 
 
When profile is required, click on Drawings > Profile. This will open a small window asking about the 
sheet planning. 
 

 
 

Fig: 4.9 
 

Check on the required profile drawing as existing or with design. Specify the chainage to be written in 
drawing i.e. all or at a fixed interval. If horizontal curve data is desired in drawing, check the box of 
Horizontal Curve Data.  
 
For the different elements and format for profile drawing, click format editor. 
 

 
 
 

Fig: 4.10 
 

The format editor lets the user to specify the format and the elements required in the drawing. Paper 
size can be specified. The paper size given the program is A1, A2 and A3. User can specify the plot 
length and plot height along with the scale of the drawing. Click “Ok”. 
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After done with the format editor, click “Execute”. This will give the number of sheets required for 
drawings. Now one can easily compose the drawing by changing the no. of rows and columns to plot 
all the drawings. 

 

 
 

Fig: 4.11 
 

Now click on “Draw”. If AutoCAD is not previously launched, the program will automatically launch the 
AutoCAD. The program will ask in AutoCAD to pick a point as reference for the drawing of profile. 
Click any point in AutoCAD such that it shouldn’t interfere with the other drawings in that window, if 
any. 

 
 

C) Cross-Sections 
 
To draw the cross sections, click Drawing > Cross-section. This will lunch the cross editor. The 
cross section are drawn from the cross editor. 
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Fig: 4.12 
 

Under the Drawing menu of the Cross Editor, two options of drawing are available. 
 
i) Draw Current 
 
When a single cross section which appears in cross editor is desired to be drawn in AutoCAD, this 
sub menu is used. Upon clicking this will ask for the drawing scale in which the drawing is desired in 
AutoCAD. 
 

 
 

Fig: 4.13 
 

 
If AutoCAD is not previously launched, the program will automatically launch the AutoCAD and draws 
the cross section. If AutoCAD is open, make sure that the window in which you are about to draw the 
cross section is active. The program will draw in the AutoCAD window which is active. A sample of 
drawing is shown below. 
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Fig: 4.14 
 

 
ii) Draw All 
 
When all the drawings are to be drawn in AutoCAD, use this sub menu. Upon clicking this will ask for 
the format in which the cross sections are to be drawn. 
 

 
 

Fig: 4.15 
 

The total no. of cross sections is displayed at the bottom of the cross editor. The no. of columns and 
no. rows in combination represents the no. of drawing to be drawn in one sheet. The row distance and 
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the column distance provide the spacing between the center line of one cross section to the other in 
vertical and horizontal direction respectively. Drawing of desired interval of cross section is also 
provided under “Draw Style”. If the area of cut, fill and structures are to be written in the drawing 
check “Write Area”. Further, if the format box comprising of Chainage and RL is desired, check “Write 
Chainage and RL”. 
 
After finalizing the format parameters, the cross sections are drawn in the AutoCAD in two ways. If the 
no. of cross sections to be drawn is of the order as given in form of no. of rows and columns only, click 
“Draw Current Sheet”. If all the drawings are desired, click on “Draw All Sheets”. This will draw all 
the sheets in the AutoCAD. This facility provides much ease in printing as one has not to break the 
sheets for cross sections. A sample is as shown below. 
 

 
 

Fig: 4.16 
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INTERACTIVE DESIGN 
 
 
 
 

 
 
 

Fig: 5.1 
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FINAL ALIGNMENT 
 
 
 
 

 
 

 
 
 

Fig: 5.2 
 
 
 

 
   
 
 



 

  
 

 77

 
DESIGNED PROFILE WITH HORIZONTAL CURVE DATA 

 
 
 

 
 
 
 

 
 
 

Fig: 5.3 
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CROSS-SECTION  

 
 
 
 
 

 
 
 
 

Fig: 5.4 
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